Issue 62 Monday 19th July 2010

Welcome to my News Email, bringing you all the latest news, website updates and poll results from Danny's The Sims Website

Latest Updates
Question sent today by Ty replied to on the “Contact Me / Previous Questions” page

Latest News

A new car for your Sims, a possible new expansion pack, poll results, a game update and a fix

2011 Ford Fiesta Now Available For Free Download

The 2011 Ford Fiesta is now available to download for free from The Sims 3 Store:

The 2011 Ford Fiesta gets the most out of every corner, thanks to the technical precision only a Ford-tuned suspension can offer. Now your Sims can experience the Ford Fiesta Movement when you download the 2011 Ford Fiesta car and Fiesta Urban Streetscape for FREE*! The Fiesta Urban Streetscape includes items for your Sims to use around town – the Fiesta Urban Style graffiti, Never Get Lost Again street sign, Maid o’ Meter parking space with meter, Hot Stuff Crossing! sign, and Street Struttin’ Street Light sign.

It only seems to be available on the US and Canada versions of TheSims3.com, which is odd considering the terms on the page say that this offer is void in the US and Canada – unless of course I’m mis-interpreting them.
 > 2011 Ford Fiesta at TheSims3.com (Canada)

“The Sims 3 After Dark” Spotted

What could be the third expansion pack for The Sims 3 has been spotted on shopping website Play.com: “After Dark”. No information, screenshots or release date were given before the page was taken down, but the name suggests possibly a remake of The Sims 2 Nightlife – does this interest you? Tell everyone your thoughts in the comments on the website.

Poll Results: Have you bought or are planning to get The Sims 3 Design & High-Tech Stuff / High-End Loft Stuff?

Yes, I really do have some results for you – you’re not hallucinating. Half of all voters have bought The Sims 3 Design & High-Tech Stuff, with a further 10% undecided whether to buy it or not. 30% aren’t interested in the items included, and 10% think it’s too expensive. To see the results in graph form and discuss them, click below.
 > Full Results

If a poll has ended, it must at long last be time for a new one, right? Yes – the latest expansion pack for The Sims 3, Ambitions, came out recently, so I want you to tell me this: Which is your favourite profession in it? Vote now to the right of any page – there are choices for you even if you haven’t bought it!
 > Go to the website to vote!

New The Sims 3 Game Update Stops Sims Walking On Water, More

EA has released a new The Sims 3 game update, fixing a lot of issues, including these:

  • Dead relatives will no longer appear alive in your Sims’ family trees while traveling to Egypt, China, or France
  • Sketches your Sims create using the Drafting Table are now valued properly based on your Sim’s Painting Skill Level and related Profession Level
  • Sims will no longer walk on water to view paintings placed on swimming pool walls
  • Fixed an “Error 13” issue caused by saving the game immediately before having your Sim give another Sim a makeover
  • Ghost Hunter Sims can no longer “Show Off Banshee Banisher” to child Sims
  • Fixed issue that prevented players from Changing Active Household while in Edit Town mode

Before you rush off to install it though, there’s some extra steps that may need to be taken, on top of the usual ones. As to be expected EA have forgotten about Windows Vista and Windows 7 and provided file paths in the instructions that only apply to Windows XP – the path to the The Sims 3 folder in Windows Vista and Windows 7 is C:\Users\[User name]\Documents\Electronic Arts\The Sims 3 (the Documents folder appears as My Documents in Windows 7, but this path is still correct). For the extra special steps, the full list of changes, and the usual steps (in that order), click below then find the post titled “Game Update for: 1.14/2.9/3.5/4.2″:
 > News at TheSims3.com (UK)

Create A World Tool Fix Released

Installed the The Sims 3 update above or Ambitions then found the Create a World Tool no longer works? Well EA have you covered with a fix. Uninstall the previous version through the Windows Control Panel (Add/Remove Programs in Windows XP, Programs > Programs and Features in Windows 7 and I think Windows Vista), then install the new version available at TheSims3.com. The tool remains in beta for Windows only.
 > Create a World Tool at TheSims3.com

Source: News at TheSims3.com (UK)

Discuss this news on the website!

Current Poll Results
Which is your favourite profession in The Sims 3 Ambitions?

Fire fighter:

0%

Architectural designer:

0%

Stylist:

0%

Tattooist:

0%

Inventor:

0%

Ghost hunter:

0%

Doctor:

0%

Investigator:

0%

Not sure yet!:

0%

I may find out after I get around to buying it!:

0%

I don't have Ambitions yet - and I haven't decided whether to buy it or not:

100%

Well I'm never buying Ambitions so I'll never know:

0%

What the heck is Ambitions?:

0%

Go to the website to vote!

Results were correct when this News Email was sent

Previous Poll Results
Have you bought or are planning to get The Sims 3 Design & High-Tech Stuff / High-End Loft Stuff?

Yes:

50%

I haven't decided whether to get it yet:

10%

No, I'm not interested in the items included:

30%

No, it's too expensive:

10%

No, I don't play The Sims!:

0%

I've never heard of it:

0%

Go to the website to discuss these results


Last issue's quiz question:
Only one Stuff Pack for The Sims 2 had a patch released for it - which one?
The answer was Family Fun Stuff

The contents of this box is copyright © 2010 Danny Cox

Do not contact me using the email address used to send the email, as I never look at that inbox. If you wish to contact me, please use the form or email address here. Danny's The Sims Website is not responsible for the content of external internet sites.

Danny's The Sims Website